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MICROSOFT EXCEL 

 

Chapter I 

Microsoft Excel Startup 

 

 

Microsoft Excel is a spreadsheet application used to process business and financial calculations 

of various kinds. To carry its various tasks, the application organizes each one of its files, also 

called a workbook, into sub-files called worksheets. You can have just one worksheet in a 

workbook or you can have a lot of worksheets in a workbook. 

 

When Microsoft Excel starts, it is ready to receive your instructions. The application opens with 

an empty document; impressive and quite unfamiliar the first time you launch it. Versions 97 and 

2000 have only slight differences, but if you have used versions 7 and/or 97 and are now in 2000, 

you will have a very smooth transition. If you are new to this kind of spreadsheet application and 

are using 2000, you will feel comfortable in no time. First, get acquainted with the interface; 

spend some time using the software, that's how you will build your experience. 

  

To start Microsoft Excel, from the Taskbar, click 

Start -> Programs -> Microsoft Excel. 
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1. Microsoft Excel is  

 

Microsoft Excel is a classic computer application and easily recognizable if you have spent some 

time with other Microsoft Office applications. On top of the application, you see the title bar  

Right to the application icon is the name of the program, in this case, Microsoft Excel. The 

application's name is followed by the workbook's name, Book1. 

  

Microsoft Excel identifies each one of its files as a workbook, and by default, a starting 

document in Microsoft Excel is called Book1. Microsoft Excel is a Multiple Document Interface 

(MDI), which means you can open more that one file, more than one workbook, inside the 

application. Therefore, if you create or initialize more than one workbook in Microsoft Excel, 

subsequent workbooks would be called Book2, Book3, BookX. 

 

To see what you can do with the title bar, double-click on the title bar, for example on the right 

side of the word Book1; that will restore the application 
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Chapter II  

Columns, Rows, and Cells 

The Workbook 

Microsoft Excel is primarily a regular application used to create files that can be used on the 

computer. Its types of files are especially made for finance and related operations. Based on this, 

a Microsoft Excel file is called a workbook. Like any other file, you can check its size and some 

other properties that each computer file shares. Therefore, from now on, we use the word 

workbook to refer to a Microsoft Excel file. To check the size of a file, you can open Windows 

Explorer or My Computer, right-click the file and click Properties. 

When Microsoft Excel starts, it displays a large window divided in various boxes. To manage 

these boxes, they are divided in columns and rows. 

 

Introduction to Columns 

A column is a vertical rectangular box. It can be used to create a list of items. To allow you to 

create various lists, there are various columns. In Microsoft Excel, each column is identified with a 

letter or two. The box that contains the letter or group of letters is called a column header. The first 

column header has the label A. The second is labeled B. The other subsequent column headers use 

the other alphabetical letters up to Z. After Z, the next column is labeled AA, followed by AB. 

This continues for a total of 256 columns where the last column is labeled IV. There are various 

actions you can take to manage columns. Some other actions are not possible. 

We have mentioned that each column has a label. Unfortunately, you cannot change the label on 

the column header. 

 

Introduction to Rows 

While a column is used to create a list or items that share a common criterion, if you are various 

columns to create different lists, a row can be combine corresponding items of each list to create 

a record. That's the traditional role but in Microsoft Excel, it doesn't have to be strictly like that. 
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A row is a horizontal box that also creates a list of items. In the strict sense, a row is used to 

create a record that is a set of items of different categories. For example, if you use one column 

to create a list of students' name, another column to create a list of their home telephone 

numbers, and another column to list their gender, you can use a row to include all entries that 

belong to only one student. 

Each row starts on the left with a gray box, also called a row header. To manage the rows, each 

displays a numeric label. The most top row header has a label of 1. The second is 2, etc. Like the 

column, you cannot change the label of a row. 

 

 

 

Introduction to Cells 

In order to process its data, each piece of information on a worksheet is stored in a particular cell. 

A cell is the intersection of a column and a row. With 255 columns and 65536 rows, there are so 

many cells you will have to deal with. Fortunately, most of the time, you will work with only a 

very low count of these cells. 

Location of a cell 

Whatever you are doing on a cell, it is always important to know what cell you are working on. 

The minimum piece of information you need about a cell is to know which one you are using at a 

particular time. To make this recognition a little easier, each cell has an address or a location. 

This address or location also serves as the cell's primary name. 

To know the location of a cell, you refer to its column and its row. The combination of the 

column and the row's labels provides the address or name of a cell. When you click a cell, its 

column header receives a border thicker than the other column headers. In the same way, the row 

header of a selected cell is thicker than the other row headers. To know the name of a cell, you 

can refer to the Name Box, which is located at the intersection of columns and rows' headers: 
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Worksheets 

Properties of Worksheets 

When you open a workbook, your primary purpose is probably to enter numbers and perform 

calculations. To manage such operations, a large window is presented to you. That window is 

called a worksheet. A worksheet is in fact a group of columns and rows that create cells. When 

Microsoft Excel opens, it starts with three worksheets. If you don't need all of them, you can 

delete those that appear useless. You can also add new worksheets as you see fit. Therefore, a 

workbook can be organized in various worksheets. 

As mentioned already, by default Microsoft Excel displays three worksheets when it starts. If you 

want it to always start with less or more, you can change its default settings in the Options dialog 

box accessible from the Tools menu. Even when they belong to the same workbook, worksheets 

can be treated as independent entities, although it is more suitable that they be treated as a unit. 

Selecting a Worksheet 
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In some circumstances, you will need to perform a general action on a worksheet. Before doing 

this, you may need to select the contents of the whole worksheet first. 

Since there are usually many worksheets presented to you, each worksheet is represented by a tab 

on the lower left corner. Therefore, to select a worksheet, you can click its tab. To select a 

worksheet using the mouse, you can press and hold Ctrl. Then press either Page Up or Page 

Down. Once the desired worksheet has been selected, you can release Ctrl. 

If you have many worksheets, to select a range of worksheets, click a tab that is considered one 

end of the range. Press and hold Shift, then click the tab at the end of the range and release Shift. 

To select worksheets at random, click one of the desired worksheets. Press and hold Ctrl. Then 

click each desired worksheet. When the selection has been made, release Ctrl. 

 

Worksheets Names  

The starting worksheets are named Sheet1, Sheet2, and Sheet3. You can change any or all of 

these worksheet names. 

To rename a worksheet:  

¶ You can double-click its sheet tab, then type a new name  

¶ You can right-click a sheetôs tab, click Rename, and type the new name  

While a certain worksheet is selected, on the main menu, you can click Format -> Sheet -> 

Rename, and type the new name 

 

Worksheets Sequence  

By defaults, worksheets are positioned in a numbered format that makes it easy to count them. 

More often you will find that, after creating a few of them, you are not satisfied with their 

positions. You should be able to reposition them in a manner that suits your particular scenario. 

To move a worksheet, click and hold the mouse on its tab, then move the mouse in the direction 

of your choice. While you are moving the worksheet, the mouse pointer will turn into a white 

piece of paper and a small down-pointing triangle will guide you. Once the small triangle is 

positioned in the desired location, release the mouse. 



7 

 

Pyr@mide Corpor@tion 

Site web: www. pyramidecorporation.com 

Email: info@pyramidecorporation.com 

Tel: 0788620201 
 

 

Adding and Removing Worksheets 

As mentioned already, when Microsoft Excel comes up, it displays three worksheets. We also 

mentioned that you can change this default number in the Options dialog box. You can add a new 

worksheet anytime if you judge it necessary. 

Some workbooks are quite complete with just one worksheet, but others need as many 

worksheets as possible. The number of worksheets you use in a particular workbook is 

conditioned by your needs and the memory of your computer. 

The easiest way to insert a worksheet in your workbook is by clicking Insert on the main menu, 

and then clicking Worksheet. This would add a new sheet on the left side of the active worksheet. 

You can also add a blank or formatted worksheet. Right-click the sheet that will precede the new 

worksheet and click Inserté From the Insert dialog box, you can choose to insert a blank 

worksheet or insert one of the existing templates as a worksheet. 

 

Selecting and Editing Multiple Worksheets 

By default, when entering data in a spreadsheet, only one worksheet and only one cell are 

selected at a time. If you have a lot of similar data to type on multiple worksheets, you may have 

to retype or copy and paste the same data to subsequent sheets. 

Microsoft Excel allows you to work on more than one worksheet at a time. First, select which 

worksheets will be involved in the group, then proceed on entering data. The information you 

type on one worksheet in a group is also entered into the other worksheets in the group. 

 

Freeze and Unfreeze Worksheets 

When working on a considerably long and large project, a worksheet can easily grow wide and 

tall. You might end up editing data without knowing the pertinent column or row headers you are 

working on. To always keep a particular column, row, or section fixed and un-scrollable, you can 

freeze  

¶ A column to keep its left columns fixed  

¶ A row to keep its top rows fixed  
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¶ A cell to keep its upper and left sections fixed  

To freeze a column, click the column header that precedes it, and then on the main menu, click 

Window -> Freeze Panes. The scrolling action will scroll only the columns starting with the one 

that was selected. 

To freeze a row, click the row header under the one you want to freeze. Then, on the main menu, 

click Window -> Freeze Panes. The scrolling action will work only on the rows under and 

including the selected row. 

To freeze the intersection of columns and rows of a particular cell, click the cell under the one 

you want to freeze. Then on the main menu, click Window -> Freeze Panes. When scrolling 

vertically, the cell above the selected cell will be fixed. When scrolling horizontally, the cell on 

the left of the selected cell will be fixed. 

To unfreeze the column, the row, or the cell, on the main menu, click Window -> Unfreeze 

Panes. 

 

 

 

 

 

Hide and Unhide Columns ï Rows ï Worksheets 

When editing data, you donôt always need all columns and rows displaying all the time. You can 

hide those items whose presence is not required at a particular time. In Microsoft Excel, you can 

hide one or many columns, one or many rows, one or many worksheets, or the entire workbook. 

To hide a column, while the column or a cell in that column is selected, on the main menu, click 

Format -> Column -> Hide. The column will disappear from the screen but it is not deleted. To 

unhide the column, on the main menu, click Format -> Column -> Unhide. 

To hide a row, while that row or a cell in that row is selected, on the main menu, click Format -> 

Row -> Hide. The row will disappear from the screen without being deleted. To unhide the row, 

on the main menu, click Format -> Row -> Unhide. 
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To hide a worksheet in a workbook, click any cell in that worksheet to make it active. On the 

main menu, click Format -> Sheet -> Hide. The worksheetôs tab will disappear from the screen 

although it is not deleted. To hide a group of worksheets, selected the desired worksheets. Then, 

on the main menu, click Format -> Sheet -> Hide. To unhide the hidden worksheets, on the main 

menu, click Format -> Sheet -> Unhide. You are presented with a list of the hidden worksheets. 

If you have more than one hidden 

 

 

Chapter III  

        Data Entry 

Introduction to Cells Text 

 

As you are aware, when Microsoft Excel starts, it opens a workbook made of three worksheets. A 

worksheet is simply made of cells that are patiently waiting for you to enter data. You should 

first practice typing different kinds of items and see what happens. 

At all times, at least one of the cells on the worksheet you are working on has focus. That cell is 

referred to as the active cell. That cell is surrounded with a thicker border. If you type something, 

it goes into the active cell. If you click a cell and start typing, the new entry will replace the 

content of that cell, whether that cell had data or not, this could be advantageous or disastrous. 

To prevent a cell from being edited by the user, you can protect it and lock its content. 

Data you type in a cell can consist of any kinds of characters, letters, numbers, etc. Sometimes, a 

long text will look like covering more than one cell; unless you merge cells, the text you type 

goes into one cell regardless of the length of the text. 

A cell can contain as many as 64000 characters. 

 

 

Text Editing 
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Data that you type in a worksheet is in fact entered in cells, except when you are drawing. To use 

Microsoft Excel with more finesse, you should familiarize with cells, their functionality, their 

configuration, and their relationships with each other and with the whole software. 

The primary technique you can use to get acquainted with the software is by entering data, 

primarily text, then manipulate various components of your application in order to customize it. 

Unlike a traditional word processor, Microsoft Excel has a unique way of treating text and 

considering any data you type in a cell. You should be aware of the default settings that the 

software acts on when you type data, how it considers and treats various numbers, dates, and 

currency values, etc. 

We have already seen how to do basic data entry into cells. The entries we used so far were short 

expressions consisting of one word, we need to find out whether a cell can accept text that is 

wider than the displayed width, if so, what happens if text goes "overboard"? 

We know that data entered in a cell is confined to that cell. If you type text that is longer than the 

cell's width, the content will display fine, giving the impression that the text is covering more 

than one cell or that the cell on the right side is no more available. Data you type is always in its 

cell. If you type anything in a cell, its content will take priority in displaying its content; therefore 

the content of the left cell will appear cut. That's why you should be very familiar with the way a 

cell (any cell) displays its data, and how every cell relates to the others. 

 

Techniques Of Cutting and Copying Cells Contents 

If you have done word processing before, you are probably familiar with techniques of cutting, 

copying, pasting, and/or moving text from one part of a document to another, or from one 

document to another. Although these techniques are available here, Microsoft Excel doesn't quite 

imitate a word processor. Again, spending time with the software will increase your experience. 

When you copy or cut something, it goes in a temporary storage area where it will wait for you to 

send it somewhere else, an action called pasting. The storage area where the cut or copied data is 

sent is called the clipboard. In Microsoft Excel 97, you can store only one item at a time in the 

clipboard. If you cut or copy something, it will replace the content of the clipboard with the new 

selection. In Microsoft Excel 2000, the clipboard can contain up to twelve items. When the 

Clipboard toolbar is functional, you can select copied or cut items from its list of buttons. If you 

use more than 12 stored items, the toolbar functions on a first-in first-out basis. 

The Clipboard toolbar can be moved to any location of your choice on the screen. You can also 

hide/close it if you don't need its services. For this exercise, when the Clipboard toolbar appears, 

don't close it. Even if you are not preparing for the MOUS exam, you should learn to take 

advantage of the new clipboard. In case you are not aware, you can use the same Clipboard 
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toolbar in different applications; for example, you can have Microsoft Excel, Microsoft Access, 

Microsoft Word, and Microsoft Outlook all of them opened at the same time and sharing the 

same clipboard items.  

 

Text in Cells 

Editing cells content consists of deleting, replacing, altering, or adding something in them. You 

already know that if you click a cell and start typing, its content will be replaced with the new 

entry. If you want to add or subtract something to a cell's content, you can double-click it; this 

puts the cell in Edit mode and you can then proceed. An alternative is to give focus to a cell, then 

press F2, this also puts the cell in Edit mode; this time, the cursor is at the end of the text in the 

cell; then you can proceed. Whatever technique you use, when you have finished editing a cell, 

make sure you lose its focus by pressing Tab, Enter, or clicking somewhere else. When you are 

in Edit mode, the arrow keys are not working, and many actions are not available. 

 

Data Entry and Text Management 

The GoTo, Find, and Replace Dialog Boxes 

To locate a particular cell in Microsoft Excel, you can use the Go To dialog box. This dialog box 

recognizes cells names by applying the same conventions used by Microsoft Excel. You can get 

the Go To dialog box from the main menu under Edit. 

The shortcuts to access the Go To dialog box are Ctrl + G or F5. 

The Find dialog box allows you to find a word in your worksheet, either to simply locate a 

particular word or multiple instances of a word, or to manipulate a word or groups of words at 

will.  

The Replace dialog box allows you to find a word or group of words and to replace it with a new 

word or group of words. Both dialog boxes are available from the main menu under Edit. 

The shortcut for the Find dialog box is Ctrl + F. 

The shortcut for the Replace dialog box is Ctrl + H. 

Check Spelling 
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Although Microsoft Excel is not a word processor, since you can use it to create text documents 

such as employment applications, brochures, time sheets, etc, it can help you correct typing 

mistakes of various kinds. It is a good idea to check spelling mistakes in your document before 

printing it or sending it for an important business transaction. The check spelling is done with the 

help of a Spelling dialog box that will take you step by step to every word that is questionable. 

Also, the computer will point out some suggested words that you can use instead of the one at 

fault. 

You can check your worksheet's spelling during or after editing, though the latter is better. To 

check your document, click the Spelling button on the Standard toolbar or on the main menu, 

click Tools -> Spelling... The shortcut to access the Spelling dialog is F7.  

 

 

Exploring Cells Content 

Introduction  

Microsoft Excel shares a lot of characteristics with window applications: the ability to search 

through the document for a particular word or phrase, the ability to find a word or group of words 

and replace it with another word or expression. 

A feature unique to Microsoft Excel as a spreadsheet application is the ability to fill out some 

cells with values that belong to a common series.  

Overview of AutoFill  

Microsoft Excel recognizes series of items so far as they can be clearly identified, either by the 

common language or by defining them explicitly in a worksheet. Common series include time, 

dates, weekdays, or months. Whenever Microsoft Excel can identify the content of a cell as being 

a series, you can use the Fill Handle to copy adjacent values of the series to neighbor cells. If a 

series is not obvious, you need to clearly define it so the application can recognize the allure you 

want to use for the series. 

 

 

Chapter IV  



13 

 

Pyr@mide Corpor@tion 

Site web: www. pyramidecorporation.com 

Email: info@pyramidecorporation.com 

Tel: 0788620201 
 

Introduc tion to Cells Formatting 

From the previous lessons, you are already familiar with the way Microsoft Excel displays text 

(left aligned) and numbers (right aligned). In some situations, you will want to treat numbers as 

text.  

To display a number as text, append a single quote (') to its left. For example, to display 908 as 

text, type '908 in the cell where you want to display 908. The single quote will not display and 

will not print, but the number, treated as text, will be left aligned.  

Although Microsoft Excel displays all numbers right aligned, as a smart financial and business 

application, it can distinguish between different types of numbers. It can recognize a date, a 

currency, or a percentage values. But the computer wants you to specify the way numbers should 

be displayed, giving you the ability to decide what a particular number represents, not because 

the software cannot recognize a number, but because a value can represent different things to 

different people in different scenarios. For example 1.5 might represent a half teaspoon in one 

spreadsheet while the same 1.5 would represent somebody's age, another spreadsheet's 

percentage, or etc.  

Microsoft Excel can recognize some numbers by default and would not need much configuration, 

if any. For example, if you type 12/05/1998 in a cell, Microsoft Excel will recognize it as a date 

and act accordingly. 

 

 

 

Introduction to Numbers Formatting  

From the previous lessons, you are already familiar with the way Microsoft Excel displays text 

(left aligned) and numbers (right aligned). In some situations, you will want to treat numbers as 

text.  

To display a number as text, append a single quote (') to its left. For example, to display 908 as 

text, type '908 in the cell where you want to display 908. The single quote will not display and 

will not print, but the number, treated as text, will be left aligned.  

Although Microsoft Excel displays all numbers right aligned, as a smart financial and business 

application, it can distinguish between different types of numbers. It can recognize a date, a 

currency, or a percentage values. But the computer wants you to specify the way numbers should 

be displayed, giving you the ability to decide what a particular number represents, not because 
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the software cannot recognize a number, but because a value can represent different things to 

different people in different scenarios. For example 1.5 might represent a half teaspoon in one 

spreadsheet while the same 1.5 would represent somebody's age, another spreadsheet's 

percentage, or etc.  

Microsoft Excel can recognize some numbers by default and would not need much configuration, 

if any. For example, if you type 12/05/1998 in a cell, Microsoft Excel will recognize it as a date 

and act accordingly. 

 

Introduction to Numbers Formatting  

When it comes to displaying items, Microsoft Excel uses various default configurations, ranging 

from the font used by your application to the actual display of numbers in cells. The computer's 

Regional Options or Regional Settings govern how dates, numbers, and time, etc get displayed 

on your computer. 

Microsoft Excel recognizes numbers in various formats: accounting, scientific, fractions, and 

currency. As the software product can recognize a number, you still have the ability to display 

the number with a format that suits a particular scenario. 

Before finding out how to display numbers in different situations, you should be familiar with the 

way the application treats your numbers. That's why once again we will review some of the 

things we have already learned. 

 

 

 

 

 

 

 

Introduction to the Format Cells 
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Although you can do most of cells configurations using the Formatting toolbar, Microsoft Excel 

provides the Format Cells dialog box. This dialog box presents more options and precision than 

the toolbar. 

To display the Format Cells dialog box, you can click Format -> Cells on the main menu. You 

can also right-click the cell or group of cells whose format you want to change and click Format 

Cells. The shortcut to access the Format Cells dialog box is Ctrl + 1 

The Number Property Page 

The object used to manage the value of a cell or the values of a group of cells on the Format 

Cells dialog box is the Number property page: 

 

The left section of the Format Cells dialog box displays the Category list box. This allows you to 

select the type of value that the cell or group of cells contains. After selecting a category, the 

right section of the property page changes, depending on the category that was selected. We are 

going to see various options available. 
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Special and Custom Formats 

Although Microsoft Excel can recognize number formats of various kinds, sometimes none of 

the preset formats will suit a particular need you have for a certain cell or group of cells. You can 

use either one of the Special Formats or create your own. 

The Special formats can be accessed from the Format Cells dialog box. These formats allow you 

to specify a cell or column for US ZIP Codes (5 or 5+4 number digits), phone numbers, or Social 

Security Numbers. 

To create your own custom format, from the Format Cells dialog box, click the Custom category, 

select one of the existing formats, then proceed to create your own by adding appropriate or 

subtracting undesired characters. 

If you get to using a worksheet that was prepared by someone else (or you) and find out that the 

format used by a cell or some cells is not appropriate, you can change it using the Format Cells 

dialog. Right-click the appropriate cell (s) or column (s) and choose Format Cells. In the 

Category list, select one and in the right list, select the format you like. 

 

The Computer's Regional Settings 

Many settings that control how your computer displays dates, time, and other numbers are 

configured in the system Registry and controlled by the computer itself. This makes sure that 

your computer is in tune with the language you use in your computer experience and certainly 

keeps you synchronized with your computer neighbors. 

The computer's Regional Settings can be viewed and/or changed from the Control Panel by 

double-clicking the Regional Settings icon. 

From the Taskbar, click Start -> Settings -> Control Panel  

In Control Panel, double-click Regional Options or Regional Setting 
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Text And Cells Formatting: AutoFormat  

A good worksheet is not simply determined by its functionality, its look plays a great deal and 

reflects your tastes in fonts, styles, and design. Before we experiment with its design capabilities, 

we will first find out how Microsoft Excel can help with choosing fonts, font styles, sizes, and 

colors. 

Cell formatting allows you to control how text displays in your cells, how much room various 

columns and rows need in order to display their content. Microsoft Excel ships with sample table 

with each configured to suit a specific scenario. Whenever possible, or you are simply in a hurry, 

use one of these readily available samples; one of the sample AutoFormat tables can make your 

table or part of your worksheet look professional. 
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To use the AutoFormat, first select the cells you want to format; then on the main menu, click 

Format -> AutoFormat... From the AutoFormat dialog box, select the style you want and click 

OK. You can change your style any time and many times until you are satisfied. 

 

Chapter V 

Formatting Cells Contents 

Cell Alignment,Cells Merging 

When reviewing cells, we found out that a cell doesn't have dimensions of its own. Its width is 

imposed by its parent column and its height is set on its parent row. All of the cells we have used 

so far were considered individually. Microsoft Excel allows you to combine various cells in a 

group. This is referred to as merging cells. 

To merge cells, select them and, on the Formatting toolbar, click the Merge and Center button. 

Cells Content Alignment 

We have already seen how Microsoft Excel differentiates data you enter into cells. Sometimes its 

default configurations will not suit your particular scenario, you should be able to control how 

text is aligned in cells. 

Since a cell is really a rectangular box, you can completely control how text is displayed inside of 

it: left, right, top, bottom. As we move on, we will see various situations of aligning cells content. 

Cells Content Indentation 

In the previous section, we used the Center button to center the content of a cell with regards to 

the width of the cell. In some circumstances, you may not want to center text but you would not 

like to keep it left or right aligned. Indentation consists of "pushing" text to the left or the right 

without centering it. 

To indent the contents of a cell or of a group of cells, after making the selecting, on the Formatting 

toolbar, you can use the Increase Indent button to "push" the contents of a cell or a group of cells 

to the right. The Decrease Indent button produces the same effect in the left direction. 

 

The Alignment Property Page 
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Besides using the alignment buttons on the Formatting toolbar, to be more precise or to perform 

various actions in one step, you can use the Alignment property page of the Format Cells property 

sheet: 

 

 

To provide the same options as the Formatting toolbar, the Alignment property page is equipped 

with the Horizontal combo box. Besides the left, center, and right alignments, this combo box 

goes further and allows text to be justified. This can be useful especially if the text is 

significantly long. If you select to indent text, you can use the Indent spin button to specify the 

number of units to indent by. 

The Vertical combo box provides options not available on the Formatting toolbar. It allows you 

to align the contents of a cell towards the top, the middle or the bottom area of a cell. 

The Text Control section provides three options: Wrap Text, Shrink To Fit, and Marge Cells. 

The Orientation  section allows you to "bend" text by a fix angle. There are two main ways you 

can set an angle. If you drag the small red diamond, you can use it to specify the desired angle. 

You can also click one of the arrows of the Degrees spin button. 

 Cells Borders 
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The alignment we have used so far is applied to the contents of a cell or of a group of selected 

cells. As we have mentioned already, a cell appears and behaves like a rectangular box. As such, 

it has borders and a background. Microsoft Excel provides a default appearance for a cell with 

regards to its background. For example, it surrounds the cell with a gray border and a white 

background. You can keep these defaults or you can change them as you see fit. 

Once again, to format a cell, you can use the Formatting toolbar. It is equipped with the Borders 

button. To change the borders of a cell or a group of cells, first select it. If the Borders button 

already displays the type of border you want, you can just click it. Otherwise, to select a type of 

border, you can click the arrow of the Borders button. It would display a window with preset 

borders: 

 

To help with recognizing  borders, each button displays it own tool tip. To find it out, you can 

position the mouse on a button for a few seconds. From now on, we will refer to each button or 

border by its tool tip. 

To help with recognizing  borders, each button displays it own tool tip. To find it out, you can 

position the mouse on a button for a few seconds. From now on, we will refer to each button or 

border by its tool tip. 

Once you see a border you like, you can click it. After clicking a preset, the Borders window 

closes and the button becomes as it was before. The clicked border would become the default 

selection on the Borders button. If you are doing a lot of borders formatting, you can click the 

arrow of the Borders button to display its window. Then, on the Borders window, you can drag its 

blue bar away from the toolbar. This would keep the Borders window permanently opened. Once 

you don't need it anymore, you can close it as you would close any window. 

The Border Property Page 

You may realize soon that, despite its list of patterns, the Borders button of the Formatting 

toolbar has some limitations. Normally, it was created to provide the most regularly applied 

borders. To apply more options, the Format Cells dialog box provides the Border property page: 
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The Cell's Background 

Introduction  

The cell background is the color or pattern that fills its inside. The default background of a cell is 

white. There are various options available to you if you want to change it. 

Once again, the Formatting toolbar provides the quickest means of configuring a cell or a group of 

cells. To paint a cell or a group with a color other than white, after selecting it, you can click the 

arrow of the Fill Color button. 

 

The Pattern Property Page 

As we have seen so far, the Format Cells dialog box provides an extensive array of options for 

cell configuration. It is equipped with the Patterns property page that displays a wide range of 

colors:  
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To change a cell background, use one of the colors on the Cell Shading section of the Patterns tab. 

It offers a list of colors you can use to configure a cellôs background by changing the Cell Shading. 

 

Style and Conditional Formatting 

Formatting With Style  

In the previous lesson, we reviewed various techniques of formatting cells. Microsoft Excel 

provides a faster and customized technique used to to apply a particular and user-created format 

that can be applied to a series of cells. As effective as that technique is, it has its own limitations. 

For example, it cannot create merge-and-center-related styles. Therefore, you should already 

remember the basic means of cells formatting, which include using either the Formatting toolbar or 

the Format Cells dialog box. As a reminder, we will review them here. 

 

Cells Formatting With Styles 
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A formatting style is a set of font, font size, color, and patterns designed to make a worksheet or 

one of its sections look good. Microsoft Excel is equipped with categories of styles. You can use 

those ones or create your own. 

When applying a style, you decide to format various cells at the same time using a category of 

style that has been predefined. Therefore, you apply such a style to a cell or range of cells. By 

default, when you are typing data in a worksheet, you are already using a predetermined style 

made of a certain font (Arial), a font size (10), a border, and background, etc. You can modify 

this style or create a new one. 

You select, create, or define a style using the Style dialog. The Style dialog is available from the 

Format menu 

 

Conditional Formatting  

Conditional Formatting allows you to define and apply formatting to some cells, text, and 

numbers based on criteria that you set. For example, you can format a time sheet to point out 

whenever an employee gets overtime. You can also use it to track the best sales people in a 

company by setting a quota that makes a cell range particular. 

To use, define, and apply conditional formatting, first select the cells that will be considered. On 

the main menu, click Format -> Conditional Formatting... You can use any criteria of your choice. 

The formatting could be applied to cells' values or a particular formula. 

 

 

Chapter VI  

Graphics And Drawing 

Microsoft Excel is equipped with drawing features that can be used to embellish a worksheet. If 

you have used Microsoft Office long enough, you are probably aware of its drawing tools. They 

allow you to draw lines, other geometric shapes, and various flowcharts, connectors, banners, etc. 

 

The Drawing Toolbar 
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The drawing in mainly done using the Drawing toolbar. 

 

The Drawing toolbar is usually available on the bottom section of Microsoft Excelôs interface. If 

you donôt see it or to display and hide it anytime, right-click any button on any displayed toolbar. 

If Drawing has a check mark, this means that the Drawing toolbar is currently displaying on your 

screen. To hide it, you can click Drawing and the toolbar would disappear. If Drawing doesnôt 

have a check mark, you can then click it to reveal the Drawing toolbar. You can also get access 

to any toolbar by using the main menu where you would click View -> Toolbars, then proceed 

the same way as described above. Another way you can control the toolbars is from the main 

menu where you would click Tools -> Customize. 

Although the Drawing toolbar is dockable, which means you can position it on the top, on the left, 

or on the right sides of your screen, it is better to keep at its default and usual position, which is at 

the bottom of your screen. 

 

Shapes 

A shape is an aesthetic figure you draw on a worksheet. There is no strict rule that defines what a 

shape looks like.  

To draw a shape, click it on the Drawing toolbar, then on the worksheet, click one of the extreme 

end, drag to the other extreme, when you get a satisfying size and orientation, release the mouse. 

Once you release the mouse, the object will still be selected with various object handles of various 

sides and corners of the object. If you position your mouse on different handles or on the object, 

the mouse pointers will have different shapes. 

 

  

This shape 

Allows you to 

 

 
Move the whole object 

 

 
Resize the object vertically 
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Resize the object horizontally 

 

 
Resize the object in up-left down-right orientation 

 

 
Resize the object in down-left up-right orientation 

 

 
Reorient an AutoShape 

 

 

 

Some objects donôt display all these mouse pointers and some may display different mouse 

shapes. If/when one of those unusual pointers comes up, you will be guided on its meaning. 

Almost any shape you draw has a marking rectangular box around it. This allows you to work on 

the shape as an object. For example, you can use this box to move the object. 

You can move any object to a new location on your screen. Sometimes you will want to select 

more than one object to manipulate the group. To select more than one object, click one of them, 

press and hold Shift, and click the other object(s). When you have created the group, release 

Shift. 

A drawn object can be copied and pasted to another location on the same worksheet or to a 

different worksheet on the same workbook, in another workbook, or even to another file. To copy 

an object, click it. Then on the main menu, click Edit -> Copy, and proceed with pasting. You can 

copy one object or a group of objects. Using the new Clipboard toolbar of Microsoft Office 2000, 

you can copy up to 12 objects at once, then paste them to their new respective locations. Just keep 

in mind that these objects will not have explicit names. 

 

Microsoft Office WordArt  

A Microsoft Office WordArt is a fancy formatted sentence whose features you can use to include 

a good-looking group of words that you type and embed in your worksheet. 

To get a WordArt, you can click the Insert WordArt button on the Drawing toolbar. From the 

WordArt Gallery dialog, select the style you like and click OK. Type the desired sentence; you 

can also change the font and/or font size before clicking OK. Once the WordArt has been 

created, you can move and resize it to your satisfaction. 
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Whenever the WordArt is selected, the WordArt toolbar should be on your screen, this toolbar is 

very useful and you should always have it handy whenever you are working on a WordArt. 

Even after the WordArt has been created, you can change its wording and style. To control its text, 

when the WordArt is selected, double-click or right-click it and click Edit Text, rephrase the words 

and click OK. To change the WordArt style, click the WordArt Gallery button the WordArt 

toolbar, select a new style and click OK. 

 

Chapter VII  

Operators and Operands 

Types of Values 

An expression is a combination of values and symbols used to produce a new value. To do this, 

there are different types of values involved in an expression.They are: 

 

A string is an empty space, a character, a word, or group of words considered as an entity. Any 

combination of letters or words you can think is primarily a string. 

 

A Boolean value is one that can be expressed in only one of two values. In Microsoft Access, a 

Boolean value is expressed as either TRUE or as FALSE. A FALSE value also has the value of 0. 

In this case, any other numeric value is considered TRUE. Boolean values are mostly used in 

comparisons. 

 

An integer is a natural number that displays without a decimal place. Examples of integers are 18, 

16763, and 1450. If the number is very large, it can be considered as a Long integer. 

 

A byte is a small integer that ranges from 0 to 255. 

 

A double, also called double precision, value is a number that can display a decimal portion, using 

the character set as the decimal separator in Control Panel. For US English, that character would 

be the period. The expression ñdouble-precisionò means that this number provides a high level of 

precision. If you are dealing with a decimal number but precision is not important, then the number 

can be represented as a Single. Valid decimal numbers are 12.55, 3.14159 or 9.80336 

 

A date is a numeric value that counts the number of days that have elapsed from a certain point of 

reference. How a date displays in a field is based on some conventions set by Microsoft Excel, 

Microsoft Windows, or you. There are also rules you must respect. Examples of dates are 

28/06/1998, 10-8-82, January 10, 1865 
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A time is a numeric value that counts the number of seconds that have elapsed since midnight of a 

certain day. The time also displays following some conventions set in Control Panel, by Microsoft 

Excel, or the person who created the spreadsheet. Examples of time values are 10:42 AM and 

18:06 

 

The currency is a numeric value used to represent money. In some cases, you can use a double-

precision value in place of the currency but because Microsoft Excel is equipped for accounting, 

you can safely take advantage of the currency type. When using currency rightly, its number 

presents the character specified in Control Panel. For US English, such a character is $. 

Constants 

A constant is a value that does not change. The constants you will be using in your expressions 

have already been created and are built-in Microsoft Excel. Normally, Visual Basic for 

Applications (VBA), the version of Microsoft Visual Basic that ships with Microsoft Excel also 

provides many constants. Just in case you are aware of them, you will not be able to use those 

constants, as Microsoft Excel does not inherently ñunderstandò them. For this reason, we will 

mention here only the constants you can use when building regular expressions. 

 

The algebraic numbers you have been using all the time are constants because they never change. 

Examples of constant numbers are 12, 0, 1505, or 88146. Therefore, any number you can think of 

is a constant. Every letter of the alphabet is a constant and is always the same. Examples of 

constant letters are d, n, c. Some characters on your keyboard represent symbols that are neither 

letters nor digits. These are constants too. Examples are &, |, @, or !  

 

In Boolean algebra, something is considered True when it holds a value. The value is also 

considered as 1 or Yes. By contrast, any other value is considered False, 0, or No. 

 

When a field holds a value, the value would be considered using the comparison operators we will 

learn. 

Operands and Operators 

The values we have used so far were provided in cells of a spreadsheet. In some cases, you will 

need to display a value that is a combination of other values. For example, you may need to 

combine a first name to a last name to create a full name. In another case, to calculate an 

employeeôs weekly salary, you may need to use the value of a salary and multiply it with a 

number of hours worked in a week. Most, if not all, of these expressions use what we call 

operators and operand. 

An operation is a technique of using a value or the contents of a cell, or to combine two or more 

values or contents of cells to either modify an existing value or to produce a new value. Based on 

this, to perform an operation, you need at least one value or the contents of one cell and one 
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symbol. A value involved in an operation is called an operand. A symbol involved in an operation 

is called an operator. . 

 

 

 

Regular Operators 

The Assignment Operator = 

In order to display a value in a cell, it must be preceded with the assignment operator, which is 

ñ=ò. The syntax you would use is: 

=ValueOrExpression 

The operand on the right side of the assignment operator is referred to as the right value or 

Rvalue. It can be a known value or a reference to another cell. 

 

There are two main ways we will use the assignment operator: 

¶ Imagine you already have a cell such as B12 and you want to display its value in another 

cell such as A4. In A4, you can type =B12 and press Enter. The contents of B12 would be 

provided to, and displayed in, A4  

In some other operations and functions we will learn, you can use the = operator inside of the 

expression or function to perform another, intermediary operation, such as a comparison 

Unary Operators 

 

-Ð   -6 -5 -4 -3 -2 -1   1 2 3 4 5 6   +Ð 

   0 

-Ð   -6 -5 -4 -3 -2 -1   1 2 3 4 5 6   +Ð 

A value on the right side of 0 is considered positive. To express that a number is positive, you 

can write a + sign to its left. Examples are +4, +228, and +90335. In this case the + symbol is 

called a unary operator because it acts on only one operand. The positive unary operator, when 

used, must be positioned to the left side of its operand. 
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As a mathematical convention, when a value is positive, you donôt need to express it with the + 

operator. Just writing the number without any symbol signifies that the number is positive. 

Therefore, the numbers +4, +228, and +90335 can be, and are better, expressed as 4, 228, or 

90335. Because the value does not display a sign, it is referred as unsigned. 

The Negative Unary Operator - 

In order to express any number on the left side of 0, it must be appended with a sign, namely the - 

symbol. Examples are -12, -448, and -32706. A value accompanied by - is referred to as negative. 

The - sign must be typed on the left side of the number it is used to negate. 

 

Remember that if a number doesnôt have a sign, it is considered positive. Therefore, whenever a 

number is negative, it must have a - sign. In the same way, if you want to change a value from 

positive to negative, you can just add a - sign to its left. In the same way, if you want to negate the 

value of a cell, an expression, or a function, you can type the ï operator on its left. 

 

The Double Quotes: "" 

Double-quotes are used to enclose a string. As we reviewed earlier, a string can be an empty space, 

one character, or a group of characters. Such a string must be considered ñas isò. Therefore, to 

include a string in an expression, put it in double-quotes. Examples are ñ ñ, "@", "Hermano", or 

"Rancho Cordova ". 

 

To display a string in a cell, precede it with double-quotes. For example, to display Rancho 

Cordova in cell B4, you would click B4, type ="Rancho Cordova" and press Enter. 

The String Concatenator: & 

The & operator is used to append two strings, the contents of two cells, or expressions. This is 

considered as concatenating them. For example, it could allow you to concatenate a first name 

and a last name, producing a full name. The general syntax of the concatenation operator is 

expressed as: 

Value1 & Value2 

To display a concatenated expression, use the assignment operator on the left of the string. For 

example, imagine you want to concatenate Juan to Marcus and display the resulting string in cell 

C5, in C5, you would type =òJuanò & ñMarkusò and press Enter. The result would be 

JuanMarkus. 
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To concatenate more than two expressions, you can use as many & operators between any two 

expressions as necessary. For example, to add an empty space in the above string, in cell C5, you 

would type =òJuanò & ñ ñ & ñMarkusò 

In the same way, you can concatenate the contents of various cells. 

 

The Addition: + 

The addition is used to add one value or expression to another. It is performed using the + 

symbol and its syntax is: 

Value1 + Value2 

The addition allows you to add two numbers such as 12 + 548 or 5004.25 + 7.63 

After performing the addition, you get a result. You can display such a result in a cell or use it as 

an intermediary variable in an expression. For example, to add 242.48 to 95.05 and display the 

result in cell C6, in C6, you would type =242.48 + 95.05 and press Enter. 

 

 

 

 

The Subtraction: - 

The subtraction is performed by retrieving one value from another value. This is done using the - 

symbol. The syntax used is: 

Value1 - Value2 

The value of Value1 is subtracted from the value of Value2. After performing the operation, a 

new value results. This result can be used in any way you want. For example, you can display it 

in a cell using the assignment operator as follows: 

= Value1 - Value2 
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The Multiplication :  

The multiplication allows adding one value to itself a certain number of times, set by the second 

value. The multiplication is performed with the * sign which is typed with Shift + 8. Here is an 

example: 

Value1 * Value2 

During the operation, Value1 is repeatedly added to itself, Value2 times. The result can be 

assigned to another value or displayed in a control as follows: 

= Value1 * Value2 

The Division: / 

The division is used to get the fraction of one number in terms of another. For example, to divide 

a Value1 if Value2 pieces, you would use a syntax as: 

Value1 / Value2 

After performing the operation, you get a new result you can use as you see fit. You can display in 

a cell or involve it in an expression. 

 

The Exponentiation: 

Exponentiation is the ability to raise a number to the power of another number. This operation is 

performed using the ^ operator (Shift + 6). It uses the following mathematical formula: 

y
x
 

The operation is performed as y^x and means the same thing. Either or both y and x can be 

values or expressions, but they must carry valid values that can be evaluated. 

When the operation is performed, the value of y is raised to the power of x. You can display the 

result of such an operation in a cell using the assignment operator as follows: 

=y^x 
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You can also use the operation in an expression. 

 

Parenthesis Operands () 

Parentheses are used to create sections in an expression. This regularly occurs when more than 

one operator is used in an operation. Consider the following expression typed in cell F2 as =8 + 3 

* 5. The result of this operation depends on whether you want to add 8 to 3 then multiply the 

result by 5 or you want to multiply 3 by 5 and then add the result to 8. 

Parentheses allow you to specify which operation should be performed first in a multi-operator 

operation. In our example, if you want to add 8 to 3 first and use the result to multiply it by 5, in 

the cell, you would write =(8 + 3) * 5. This would produce 55. On the other hand, if you want to 

multiply 3 by 5 first then add the result to 8, you would write 8 + (3 * 5). This would produce 23. 

As you can see, results are different when parentheses are used on an operation that involves 

various operators. This concept is based on a theory called operator precedence. This theory 

manages which operation would execute before which one; but parentheses allow you to control 

the sequence of these operations. 

 

Worksheets and Expressions 

To create a pseudo-database, you can connect worksheets that would exchange information. This is 

a valuable use of lists as one worksheet can be used to store particular information and make it 

available to other worksheets. In Lesson3, we already saw briefly how worksheets can be linked. 

We didn't expand on it because we had not been introduced to expressions or functions yet. 

Fortunately, almost any expression or function you use in the cells inside one worksheet can also 

be used in linked worksheets. 
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Chapter VIII  

Introduction to Functions  

 

A function is a small assignment that is performed to produce a result that can be reliably used 

without caring as to how the function works or how it was created. It is like when you pick up a 

TV remote control and press a button to change the channel. You donôt care how the remote 

control works and you donôt spend any time finding out why the channel changed. As in real 

world where we use various functions on cars, radio stations, food eating, etc, in the computer 

world, various functions are made available so you can simply use them to do your job. As a 

spreadsheet application, Microsoft Excel is equipped with various functions that can solve almost 

any kind of calculation. 

In order to use a function more effectively, you should first know whether it is available and 

what you need to do to make it work. A function involves four main issues: 

¶ The name of the function: Obviously, in order to use a function, you must know its name. 

Although the functions are not case-sensitive, it is a good idea to always write them in 

uppercase. 

¶ The purpose of the function: what the function used for. Different functions are meant for 

different purposes. For example, when you press the power button on a TV remote 

control, the TV gets turned ON or OFF depending on whether it was already ON or OFF. 

Therefore, the purpose of the power button is to turn the TV ON or OFF and vice versa 

¶ What the function needs in order to carry its assignment: this need is called argument (or 

arguments). A function can use more than one argument. For example, you use one key to 

turn on the car. Another function may need more than one argument. The arguments can 
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be the same kind. For example, some remote controls use two similar batteries. The 

arguments may also be different kind. 

 

On a function that takes one argument, the argument may be required. In this case, you 

must provide it. If you don't, the function will not work (the result would be an error). In 

other circumstances, an argument may not be required. In this case, if you donôt provide 

the argument, the function would use its own value, called a default argument. 

 

If a function takes more than one argument, all arguments may be required. In this case, if 

you fail to provide all of them, the function would not work. Another function that takes 

more than one argument may not require all of them. There are even cases when a 

function takes many arguments but none of them is required. When an argument is not 

required, you donôt have to supply it. If you donôt, then the function would use a default 

value for that particular function. 

 

The person who creates a function also decides on the number of its arguments, if the 

argument(s) is/are required and, if the function takes more than one argument, which ones 

are required, whether all of them are required or none of them is required. 

The result of the function: after using a function, you need its result so you can use it for its 

intended purpose. Various functions produce various results but each function is intended for a 

specific purpose. For example, one function may take two words as the first and the last name. The 

function may then produce a full name. Another function may take one number, multiply it by its 

own number, and produce a new number. Yet another function may take a sentence and a number 

then produce another value. 

 

Using a Function 

To us a function in your spreadsheet, you can display its result in a cell. Because a cell is just a box 

ready to display anything, it is your job to get the result ready to display. Fortunately, and as we 

have seen in the past, the cell is equipped to interpret values that are provided to it. 

 

If you are displaying the result of a function in a cell, the use and implementation of a function 

always starts with an equal symbol "=" followed by the name of the function. If you know the 

name of a function and its arguments, to use it, you can type = in a cell, followed by the name of 

the function, followed by an opening parenthesis. Microsoft Excel will know that you are trying to 

use a function and will offer to help. 

 

The functions that ship with Microsoft Excel can be divided in various categories. 

 



35 

 

Pyr@mide Corpor@tion 

Site web: www. pyramidecorporation.com 

Email: info@pyramidecorporation.com 

Tel: 0788620201 
 

Fundamental Functions 

Before getting into functions, let's experiment with Microsoft Excel's use and recognition of 

mathematical operations. 

Microsoft Excel is aware of such algebra operations as the addition (+), the subtraction (-), the 

multiplication (*), and the division (/). These operations can be applied to numbers typed in a cell 

when performing the operation, they can be gotten from another cell. 

 

The AutoSum 

The SUM function is the most basic and one of the most popular functions used in Microsoft 

Excel. It is used to get the addition of various numbers or the contents of various cells. The result 

can be displayed in another cell or used in an expression. 

 

The Standard toolbar is equipped with a button called the AutoSum. There are two most primary 

ways of using the AutoSum. You can click an empty contiguous cell, and then click the AutoSum 

button . Before performing the SUM function, the computer will ask whether it found the right 

cells that you want to get the sum of. If the computer found the right cells, you can press Enter; 

otherwise use your mouse or your keyboard to select the cells you want to consider. You can also 

select the cells involved in a sum plus an empty cell that will be used to display the result, and then 

click the AUTOSUM  button. 

 

1. On the Standard toolbar, click AutoSum . Notice that Microsoft Excel selects the cells 

on the upper region of the selected cells; their blinking border is the application's way of 

asking whether these are the cells you want to get the sum of 
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On the Standard toolbar, click AutoSum . Notice that Microsoft Excel displays the sum 

result directly. This is because you had selected the cells involved in the sum plus an empty 

adjacent cell that will display the result  
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2. Notice a new dialog, SUM, on the screen  

3. Position your mouse on a gray area that is not a button, then click, hold your mouse down 

and move it to a different area until you can see cell I13  

4. Notice that the Number 1 box already has the range of cells I3:I10 
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5. Click OK  

6. Right-click cell I11 and click Copy  

7. Right-click cell J11 and click Paste. Notice that the pasted result is not the content of cell 

I11, only the formula has been copied but only conform to column G  

8. Click cell J11. Position your mouse on its Fill Handle (the lower right point of the selected 

cell). Click and drag its Fill Handle to cell K11 

Notice that once again it is the formula that was copied to the subsequent cell  

Save the workbook 

 

Parentheses are used to create sections in an expression. This regularly occurs when more than 

one operator is used in an operation. Consider the following expression typed in cell F2 as =8 + 3 

* 5. The result of this operation depends on whether you want to add 8 to 3 then multiply the 

result by 5 or you want to multiply 3 by 5 and then add the result to 8. 

Parentheses allow you to specify which operation should be performed first in a multi-operator 

operation. In our example, if you want to add 8 to 3 first and use the result to multiply it by 5, in 
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the cell, you would write =(8 + 3) * 5. This would produce 55. On the other hand, if you want to 

multiply 3 by 5 first then add the result to 8, you would write 8 + (3 * 5). This would produce 23. 

As you can see, results are different when parentheses are used on an operation that involves 

various operators. This concept is based on a theory called operator precedence. This theory 

manages which operation would execute before which one; but parentheses allow you to 

control the sequence of these operations. 

 

AutoCalculate 

On the Status Bar, the AutoCalculate pane allows you to get a quick result of the most used 

functions in Microsoft Excel. 

 

1. Select cells D5:D12 and observe the AutoCalculate section of the Status Bar  

2. Right-click the AutoCalculate section (or anywhere on the Status Bar) and click None. 

Notice that the AutoCalculate section displays nothing  

3. Right-click the AutoCalculate section again and click Sum 
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 Now the AutoCalculate section displays the sum of the selected cells 

 

The Absolute Value 

The decimal numeric system counts from minus infinity (-Ð) to infinity (+Ð). This means that a  

number can be usually negative or positive, depending on its position from 0, which is 

considered as neutral. In some operations, the number considered will need to be only positive 

even if it is provided in a negative format. 

The absolute value of a number x is x if the number is (already) positive. If the number is 

negative, then its absolute value is its positive equivalent. For example, the absolute value of 12 

is 12, while the absolute value of ï12 is 12. 

 

To get the absolute value of a number, you can use one of the ABS() function. Its syntax is: 

ABS(number) 

 

 

The Ceiling of a Number 

Consider a floating number such as 12.155. As you can see, this number is between integer 12 

and integer 13 

 

On the other hand, consider a number such as ï24.06. As this number is negative, it is between ï

24 and ï25, with ï24 being greater. 

 

In arithmetic, the ceiling of a number is the closest integer that is greater or higher than the 

number considered. In the first case, the ceiling of 12.155 is 13 because 13 is the closest number 

greater than or equal to 12.155. The ceiling of ï24.06 is ï24. 

 

To find the ceiling of a number, you can use the CEILING  function used to obtain the ceiling of 

a number uses the following syntax: 

CEILING(number, significance) 

The function takes two arguments. The number argument is the one that will be considered. The 

significance argument is the nearest multiple significance 

 

The Floor of a Number 
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Consider two floating numbers such as 128.44 and -36.72. The number 128.44 is between 128 

and 129 with 128 being the lower. The number ï36.72 is between ï37 and ï36 with ï37 being 

the lower. The lowest but closest integer value of a number is referred to as its floor. For 

example, the floor of 128.44 is 128. The floor of ï36.72 is ï37. 

 

To get the floor of a number, you can use the FLOOR  function. Its syntax is: 

FLOOR(number, significance) 

The FLOOR()  function takes two arguments. The first argument argument is the number to be 

considered. The second argument is the nearest multiple of significance. 

  

The Power of a Number 
 

We saw in Lesson8 that, to raise a number to another, you could use the ^ operator. Microsoft 

Excel provides a function to perform the same operation. 

The POWER() function is used to calculate the value of one number or expression raised to the 

power of another number. It uses the formula x
y
. The syntax is of the POWER function: 

POWER(number, power) 

This function takes two required arguments. The first argument, number, is used as the base 

number to be evaluated. The second argument, power, also called the exponent, will raise number 

to this value. 

 

 

The Exponential 

Microsoft Excel provides the EXP function used to calculate the exponential value of a number. 

Its syntax is: 

EXP(number) 

The argument, number, a double-precision value, represents the number to be evaluated. If the 

value of number is less than -708.395996093 (approximately), the result is reset to 0 and qualifies 

as underflow. If the value of the argument x is greater than 709.78222656 (approximately), the 

result is infinity and qualified as overflow 

 

 

The Log10 

The LOG10 function calculates the base 10 logarithm of a number. The syntax of this function 

is: 

LOG10(number) 

The number to be evaluated is passed as the argument number. The function returns the 

logarithm on base 10 using the formula: 

http://www.functionx.com/excel/lesson10.htm#expo


42 

 

Pyr@mide Corpor@tion 

Site web: www. pyramidecorporation.com 

Email: info@pyramidecorporation.com 

Tel: 0788620201 
 

y = LOG10x which is equivalent to x = 10
y
  

 

 

The Square Root 
 

There are two forms of calculating the square root of a (real positive) number. The SQRT 

function is used to calculate the square root of a double-precision number. Its syntax is: 

SQRT(number) 

This function takes one argument as a positive floating number. After the calculation, the 

function returns the square root of x: 

= SQRT(E12) 

 

Other arithmetic functions include COMBIN, EVEN, EXP, FACT, INT, LN, LOG, LOG10, 

MOD, ODD, PI, RAND, ROMAN, ROUND, ROUNDDOWN, ROUNDUP, SIGN, SQRT, 

SUBTOTAL, SUMSQ, and TRUNC. 
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Chapter IX  

 

Collections and Business Functions 

 

Series-Based Functions 

 
A series or collection-based function is one that operates on a series of values. The values are 

stored in a collection called an array.  

 

 

The Average of a Series: 
 

The AVERAGE  function displays the average or mean value of selected cells. It takes the sum of 

the cells involved (you don't need to calculate the sum first), divides the result by the number of 

cells involved, and displays the result. 

 

We will use the AVERAGE  function to get the average grade for each student's grade. 

 

1. Open the Red Oak High School1 workbook you started in lesson 7  

2. In cell B12, type Average  

3. In cell C12, type =AVERAGE(   

4. To get the average of the first student's grade, select cells C3:C12 and press Enter  

5. Click cell C14 to give it focus  

6. On Standard toolbar, click the Paste Function button  

7. In the Function Category, click Most Recently Used. In the Function Name, click 

AVERAGE; if you don't see AVERAGE, then in the Function Category, click Statistical, 

and in the Function Name, click AVERAGE. Click OK  

8. Move the AVERAGE dialog box to the right to make sure you can see cell C14  

9. Since the AVERAGE dialog is a modeless dialog box, which means you can have access to 

the main window behind it while the dialog box is opened, select cells C5:C12. Click OK.  

Right-click cell C14 and click Copy  

Select cells D14:J14 and press Enter. Notice that since the copying was done on a cell that has a 

function's result, only the formula was copied. Also notice the errors on cells I14 and J14; don't 
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worry about those errors, they will find a solution in a few seconds 

  

The Minimum in a Series 
The MIN  function will examine the contents of selected cells and display the content of the cell 

that has the lowest (highest) value. 

 

The Maximum in a Series 

 
The MAX function is used to get highest value of a series of cells 

 

 

Counting the Number of Numeric Values in a Series 

Imagine you want to perform some type of counting in a series of cells, Microsoft Excel provides 

various functions used to count items in a collection. Everything depends on what and/or how 

you want to count. 

The COUNT function counts the number of cells that contain numbers in the range or group of 

cells involved in a collection. 

 

Counting the Number of Non-Empty Cells in a Series 
 

While the COUNT function counts the numbers, the COUNTA  function counts the number of 

non-empty cells (regardless of what is in those cells, as long as they contain something) in the cells 

involved. 

 

 

Business Functions 

 
An asset is an object of value. It could be a person, a car, a piece of jewelry, a refrigerator. 

Anything that has a value is an asset. In the accounting world, an asset is a piece of/or property 

whose life span can be projected, estimated, or evaluated. As days, months or years go by, the 

value of such an asset degrade. 

 

When an item is acquired for the first time as ñbrand newò, the value of the asset is referred to as 

its Cost. The declining value of an asset is referred to as its Depreciation. At one time, the item 

will completely lose its worth or productive value. Nevertheless, the value that an asset has after it 

has lost all of its value is referred to its Salvage Value. At any time, between the purchase value 

and the salvage value, accountants estimate the value of an item based on various factors including 

its original value, its lifetime, its usefulness (how the item is being used), etc. 

 

The Double Declining Balance 

The Double Declining Balance is a method used to calculate the depreciating value of an asset.  

To get it, you can use the DDB function whose syntax is: 
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DDB(cost, salvage, life, period, factor) 

The first argument, cost, represents the initial value of the item and it is required. The salvage 

argument is the estimated value of the asset when it will have lost all its productive value. This 

argument also is required. The cost and the salvage values must be given in their monetary values. 

The value of life is the length of the lifetime of the item; this could be the number of months for a 

car or the number of years for a house, for example. The period is a factor for which the 

depreciation is calculated. It must be in the same unit as the life argument. For the Double 

Declining Balance, this period argument is usually 2. 

 

Start a new workbook and fill up Sheet1 as follows: 

 

1. Save it as Depreciation  

2. Double-click Sheet1 to put its label into edit mode. Type Double-Declining-Balance and 

press Enter  

3. Click cell C8 and, on the main menu, click Insert -> Function...  

4. In the Paste Function dialog box, in the Function Category list, click Financial. In the 

Function Name list, double-click DDB and move the DDB window so you can see the 

values on the worksheet  

5. Click the box to the right of Cost and, on the worksheet, click cell C4  

6. In the DDB window, click the box to the right of Salvage and, on the worksheet, click cell 

C5  

7. In the DDB window, click the box to the right of Life and, on the worksheet, click cell C6  

8. In the DDB window, click the box to the right of Period and, on the worksheet, click cell 

C7  

In the DDB window, click the box to the right of Salvage and type 2 
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Click OK 

 

 

The Straight Line Depreciation 
 

Microsoft Excel provides another method used to calculate the depreciation of an item. This 

time, the depreciation is considered on one period of the life of the item. The function used is 

SLN and its syntax is: 

SLN(cost, salvage, life); 

The cost argument is the original amount paid for an item (refrigerator, mechanics toolbox, high-

volume printer, etc). The salvage, also called the scrap value, is the value that the item will have 

(or is having) at the end of Life. The life argument represents the period during which the asset is 

(or was) useful; it is usually measured in years. 
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1. Click Sheet2 and fill it up as follows: 

   

 

2. Double-click Sheet2 to put its label into edit mode. Type Straigh-Line and press Enter  

3. Click cell C8 and, on the main menu, click Insert -> Function...  

4. In the Paste Function dialog box, in the Function Category list, click Financial. In the 

Function Name list, double-click SLN and move the SLN window so you can see the 

values on the worksheet  

5. Click the box to the right of Cost and, on the worksheet, click cell C4  

6. In the SLN window, click the box to the right of Salvage and, on the worksheet, click cell 

C5  

7. In the SLN window, click the box to the right of Life and, on the worksheet, click cell C6  

8. In the SLN window, click OK   

Click OK 

 

 

1.  
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2. Click OK  

3. Notice that in our evaluation, we decided that the item would have a $0.00 value at the end 

of its life. Since this is still a big investment, it is very likely to still be very operational 

after 5 years. To experiment with different factors, let's assume that the item will have a 

value of $3500 after 5 years. 

On the worksheet, click cell C5. Type 3500 and press Enter  

4. Now, imagine that we think that the item will have a value of $0.00 after 5 years but we 

want to know how much it will have depreciated the 3rd year. 

On the worksheet, click cell C5 and type 0  

5. Click cell C7. Type 3 and press Enter 
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6. Compare with the value we got in our table above  

Save the workbook 

 

 

Chapter X 

 

Financial Functions 
 

 

Microsoft Excel provides a series of functions destined to perform various types of financially 

related operations. These functions use common factors depending on the value that is being 

calculated. Many of these functions deal with investments or loan financing. 

The Present Value is the current value of an investment or a loan. For a savings account, a 

customer could pledge to make a set amount of deposit on a bank account every month. The 

initial value that the customer deposits or has in the account is the Present Value. The sign of the 

variable, when passed to a function, depends on the position of the customer. If the customer is 

making deposits, this value must be negative. If the customer is receiving money (lottery 

installment, family inheritance, etc), this value should be positive. 

The Future Value is the value the loan or investment will have when the loan is paid off or when 

the investment is over. For a car loan, a musical instrument loan, a financed refrigerator, a boat, 

etc, this is usually 0 because the company that is lending the money will not take that item back 

(they didn't give it to the customer in the first place, they only lend him or her some money to 
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buy the item). This means that at the end of the loan, the item (such as a car, boat, guitar, etc) 

belongs to the customer and it is most likely still worth something. 

As described above and in reality, the Future Value is the amount the item would be worth at 

the end. In most, if not all, loans, it would be 0. On the other hand, if a customer is borrowing 

money to buy something like a car, a boat, a piano, etc, the salesperson would ask if the customer 

wants to put a "down payment", which is an advance of money. Then, the salesperson or loan 

officer can either use that down payment as the Future Value parameter or simply subtract it 

from the Present Value and then apply the calculation to the difference. Therefore, you can 

apply some type of down payment to your functions as the Future Value. 

The Number Of Periods is the number of payments that make up a full cycle of a loan or an 

investment. 

 

The Interest Rate is a fixed percent value applied during the life of the loan or the investment. 

The rate does not change during the length of the Periods. 

It is very important to understand how these two arguments are passed to a function. The period 

could be the number of months of a year, which is 12; but it could be another length. Suppose a 

customer is getting a car loan that would be financed in 5 years. This is equivalent to 5 * 12 = 60 

months. In the same way, a cash loan can stretch from 0 to 18 months, a carpenter truck loan can 

have a life financing of 40 months, and a condominium can be financed for 15 years of 12 

months plus an additional 8 months; this is equivalent to (15 * 12) + 8 = 188 months. Here is the 

tricky part, especially as far as Microsoft Excel deals with its finance functions. If you pass the 

number of Periods in terms of years, such as 5 for a car loan that stretches over 5 years, then you 

can pass the Rate as a percentage value, such as 8.75%. If you pass the number of Periods in 

terms of months, for example you can pass it as 44 for a car that is financed in 3 years and 8 

months, then you must communicate this to the Rate argument by dividing the Rate by 12. In 

other words, a Rate of 8.75% would be passed as 8.75%/12. If the Rate was typed in a cell 

named B2 that displays 8.75%, you can pass it as B2/12. 

For deposits made in a savings account, because their payments are made monthly, the rate is 

divided by the number of Periods of a year, which is 12. If an investment has an interest rate set 

at 14.50%, the Rate would be 14.50/12 = 1.208. Because the Rate is a percentage value, its 

actual value must be divided by 100 before passing it to the function. For a loan of 14.50% 

interest rate, this would be 14.50/12 = 1.208/100 = 0.012. 

 

The Payment is the amount the customer will be paying. For a savings account where a customer 

has pledged to pay a certain amount in order to save a set (goal) amount, this would be the 

amount the customer would pay every month. If the customer is making payments (car loan, 

mortgage, deposits to a savings account, etc), this value must be negative. If the customer is 
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receiving money (lottery installment or annuity, family inheritance, etc), this value must be 

positive. 

 

The Payment Type specifies whether the payment is made at the beginning or the end of the 

period. For a monthly payment of an item financed like a car, a boat, a guitar, or a house this 

could be the end of every month. 

 

 

 

 

 

Logical Operators and Functions 

Logical Operators 

A logical operator is one used to perform a comparison between two values and produce a result of 

true or false (there is no middle result: something is not half true or half false or "Don't Know"; 

either it is true or it is false). 

 

Equality = 
 

The equality operator is used to compare two values for similarity. The syntax of this operation 

is: 

 

Value1 = Value2 

 

If Value1 and Value2 hold the same value, then the comparison produces a TRUE result. If they 

hold different values, the comparison renders a FALSE value: 
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Once the comparison has been performed, it processes a Boolean value you can use as you see fit. 

 

 

Inequality <> 

The "Less Than" operator uses the following syntax: 

Value1 < Value2 

If Value1 holds a value that is lower than that of Value2, the comparison produces TRUE. If 

Value1 holds a value that is greater than or similar to that of Value2, the comparison renders 

FALSE 
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The equality (=) and the inequality (<>) operators are opposite each other. 

 

Less Than Or Equal <= 

  When comparing two values, you may want to know whether two fields hold the same value or 

if one is lower than the other. This comparison can be performed with the "Less Than Or Equal 

to" operator. It is represented by <=. Its syntax is:  

Value1 <= Value2  

If both operands (Value1 and Value2) hold the same value, then the comparison produces a 

TRUE result. If Value1 holds a value that is lower than that of Value2, the comparison still 

produces a TRUE result. By contrast, if the value of Value1 is higher than that of Value2, the 

comparison renders a FALSE result  

 
Note that the > and the <= operators are opposite each other. 

 

 

Greater Than Or Equal >= 

If you have two values and want to find out whether they hold similar values or the first is greater 

than the second, you can use the >= operator whose syntax is:  

Value1 >= Value2  

If both Value1 and Value2 hold the same value, then the comparison renders a TRUE result. 

Similarly, if the left operand, Value1, holds a value greater than that of the right operand, Value2, 

the comparison still produces TRUE. If the value of Value1 is less than the value of Value2, the 

comparison produces a FALSE result  
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Therefore, < and >= are opposite. 

 

 

 

Logical Functions 

 
Because Microsoft Excel is not a programming environment, it doesn't use conditional 

statements seen in traditional languages such as C/C++, Pascal, C#, Visual Basic, etc. Instead, 

Microsoft Excel provides functions that can perform the same types of tests on cells' values and 

produce the same types of results. 

A logical function is one that evaluates an expression and returns a Boolean result. For example, 

imagine you have a series of cells that represent employees last name. If you are interested to 

know what cell doesn't have a value (a last name), you can use a function. On the other hand, 

imagine you have a cell that is supposed to indicate whether an item must receive a discount, you 

can use a conditional function to check it. 

Most, if not all, logical functions check a condition and render a result. The condition is also called 

a criterion. A criterion can be something like "Check if the cell contains Male", or "Check if the 

salary is less than $12.35". 

 

 

IF 

To check whether a criterion is true or false before taking a subsequent action, you can use the 

IF()  function. Its syntax is:  

IF(ConditionToTest, WhatToDoIfConditionIsTrue, WhatToDoIfConditionIsFalse) 

When it is called, the IF()  function checks the truthfulness or negativity of the ConditionToTest 

argument. If the result is true, then it will execute the first expression, WhatToDoIfConditionIsTrue 
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in our syntax. If the result is false, it will consider the second option, the 

WhatToDoIfConditionIsFalse parameter in our syntax. 

 

Nested IF 

The IF()  function we have introduced above is used to check one condition and then take one or 

the other action. In some cases, you will need to check more than one condition. In other words, 

you may want to check a first condition. If that condition is false, you may want to yet check 

another condition. The pseudo-code used for such a scenario is: 

If Condition1 is True 

 Execute Statement1 

Else If Condition2 is True 

 Execute Statement2 

Else 

 Execute ElseStatement 

Consequently, you can check as many conditions as you need to. The truthfulness of each 

condition would lead to its own statement. If none of the conditions is true, then you can execute 

the last statement. To implement this scenario, you can include an IF()  function inside of 

another. You can also include as many IF()  functions inside of other IF()  functions. 

We are going to use the IF()  function to find out whether a student passes the mark or fails the 

class, based on the overall average of the student's grades. We will set the mark at 12.50. If a 

student's average is above 12.50, then he goes to the next grade, otherwise, é 

 

Conditional Counting 

 

In some cases you will need to count the frequency of (the number of times that) a value repeat 

itself in a series of cells. For example, suppose you have a list of students recognized by their 

gender using a certain column. Provided the genders are, for example, Male or Female. You may 

be interested in knowing the number of boys. In this case you can count the number of 

occurrences of Male in the range of cells.  

The count the number of occurrences of a value in a series, you can use the COUNTIF () 

function. Its syntax is  

COUNTIF(Range, Criteria) 

 

 

Concatenating Strings 
 

The CONCATENATE() function is used to add two or more strings to create a new string. 
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Chapter XI  

Date and Time Functions 

Dates 
A date is a number that represents the number of days that have elapsed from a set period in 

history. Microsoft Excel uses natural numbers to represent a date value as the number of days that 

have passed since 1/1/1900 on MS Windows (or since 1/2/1904 on Macintosh 

 

Date Representation 

To make a date easily recognizable, there is a formula you use, depending on the language. The 

first place you can check about representing dates is in Control Panel from the Regional Settings. 

In US English, this is represented as follows: 

 

Based on this, to represent a date (in US English), you use placeholders for numbers and a 

special symbol called the Date Separator. The default and most used date separator (in US 

English is the forward slash "/". Here is an example of representing a date: 8/5/2000. 
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Besides the numbers, you can use words to represent a date. The days of a week have names. 

There are three main ways to represent a day of a week. You can use a complete name as 

Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, and Saturday. Each of these names 

also has an equivalent short name you can use instead. They are Sun, Mon, Tue, Wed, Thu, Fri, 

and Sat, respectively. A day of a week can also be represented by a natural number. By default, 

this would be 1 for Sunday, 2 for Monday, 3 for Tuesday, 4 for Wednesday, 5 for Thursday, 6 for 

Friday, and 7 for Saturday. 

The months of a year have names. As done with weekdays, there are three main ways to 

represent a month. You can use a complete name as January, February, March, April, May, June, 

July, August, September, October, November, and December. Each of these names also has an 

equivalent short name you can use instead. They are Jan, Feb, Mar, Apr, May, Jun, Jul, Sep, Oct, 

Nov, and Dec respectively. A month can also be represented by a natural number. This would be 

01 or 1 for January, 02 or 2 for February, 03 or 3 for March, 04 or 4 for April, 05 or 5 for May, 

06 or 6 for June, 07 or 7 for July, 08 or 8 for August, 09 or 9 for September, 10 for October, 11 

for November, or 12 for December. 

When names to represent a date, you can use empty spaces to separate the components of a date. 

You can also use the comma and the empty space, where appropriate, to separate two sections of 

a date. 

Microsoft Excel as a powerful mathematical tool, recognizes all the rules of date representation 

but because there can be so many ways of stating the same value, it completely allows you to 

indicate how you want your date values to be represented. Microsoft Excel also provides 

suggestive formats you can use. 

Dates-Related Functions 

To support dates values and operations, Microsoft Excel provides many functions for various 

scenarios. With some functions, you will only use the value they provide (or return, as we studied 

about functions). With some other function, you will have to create a date by providing the 

necessary value(s) as argument(s). There are two categories of date values you will need to keep 

in mind when creating your expressions: deterministic and non-deterministic: 

¶ A date value is referred to as deterministic when you know its value with certainty. For 

example, suppose that a company decides that nobody will work on 25 December of every 

year. This is a fixed day. If you involve it in an expression, you know with certainty when 

this date occurs, which is 25 December of the year blah blah blah (the year is not important 

for this example)  

¶ A date value is referred to as non-deterministic when you cannot know in advance when 

the exact date would occur but you know it will occur. For example, suppose that a 

company decides that, if December 20
th
 occurs on Sunday, then the employees would 

receive their paychecks the Friday before, otherwise the employees would receive their 
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paychecks the following Monday. In this case, when you write the expression, you cannot 

know with certainty when the date would occur (don't think that you should/can write an 

long expression that covers dates from 2000 to 2050; although you can, this is not 

professional and it is poor development). In this case, the date value you are involving in an 

expression is non-deterministic  

For the sake of this lesson, we will use a data type called DateTime that represents a date (and/or 

a time) value. 

 

Get Today's Date 

The TODAY()  function can be used to get the current date of the computer. Its syntax is: 

DateTime TODAY() 

This function takes no argument but it returns a value that represents the date of the computer in 

which it is called. 

Create a Date 

To involve a fixed date in an expression, you can create it using the DATE()  function. Its syntax 

is: 

DateTime Date(int y, int m, int d) 

This function takes three arguments and each must be an integer. The first argument is a year 

value. It can be passed as a 2-year or a 4-year digit. That is, the year can be as a number between 

0 and 9999. If you pass the year with a single digit or two digits, like 2, 1900 would be added to 

it. For example, the number 2 would produce the year 1902. The number 08 would produce 1908 

and not 2008. Therefore, you should make it a habit to pass the year with 4-digits. This is not an 

anomaly of Microsoft Excel. It was designed like that (if this appears like a problem to you, keep 

in mind that you are not the only one using MS Excel; someone else at the NIST or the Mossad is 

using it for something else, so 02 producing 1902 and not 2002 would suit him perfectly). 

The second argument of this function represents the numeric month of the year. January is 

represented with 1 or 01, February with 2 or 02, etc. 

The third argument of this function represents the numeric day of the month.  

Here is an example typed in a cell: 

=Date(1988, 06, 05) 



60 

 

Pyr@mide Corpor@tion 

Site web: www. pyramidecorporation.com 

Email: info@pyramidecorporation.com 

Tel: 0788620201 
 

After calling this function and passing the required arguments, it produces a date value. When 

passing the value of the day, make sure you follow the rules of day values; otherwise, you may 

use an unpredictable result. If you provide an invalid date for either argument, Microsoft Excel 

would follow some algorithm to try to figure it out. For example, suppose you provide the 

following date: 

=DATE(1975, 02, 35) 

Fortunately, instead of displaying an error, Microsoft Excel would find out if the day number is 

valid. In this case it is not. Therefore, in this case, maximum number of days allowed for the 

month would be subtracted from the number you provided, the corresponding number of months 

would be added to the month value and the rest of days would be applied to the day argument: 

 

Date Conversion 

Suppose a certain cell displays some text and that text might be the value of a date. Even if you 

believe that it is a date, it may be safe to convert such text first to a recognizable date value 

before using it. To convert text to a date value, you can use the DATEVALUE()  function. Its 

syntax is: 

DateTime DATEVALUE(Text) 

This function takes one argument. The argument can be the content of a cell. When this function 

is called, it analyzes the text provided as argument. If the argument holds a valid date value, the 

function returns it. Here is an example:  

DATEVALUE("05/2/1977") 

If the argument is not a valid date, you would receive an error (#VALUE ). A remedy is to check 

if the text represents a date, then convert it, otherwise ignore it or do something else. 

 

Returns the Parts of a Date 

If a date has already been created but you want to retrieve only the year part, the month part, the 

day part, or all of the, Microsoft Excel provides three functions that can take care of this. 

Year: The YEAR()  function is used to retrieve the numeric year of a date value. Its syntax is 

int YEAR(DateTime Value) 

This function takes one argument. When called, it analyzes the argument. If the argument is a 

valid date, then the function returns its year, a value between 1900 and 9999. For example, 
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YEAR(12/05/2002) returns 2002. If you pass the argument as a (Long) natural number or a 

decimal, Microsoft Excel would use some algorithm, first to create a valid date from the number, 

second to retrieve the year part. For example YEAR(37940.574) would produce 2003. If the 

argument is not a valid date and Microsoft Excel cannot convert it a valid date, then the function 

would produce an error (#VALUE ). 

Month : The MONTH()  function is used to get the numeric value of the month of a date value. 

Its syntax is: 

int MONTH(DateTime Value) 

Day: The Day() function is used to produce the day part of a date value.  Its syntax is: 

int DAY(DateTime Value) 

 

 

Times 

A time is a decimal number that represents a fraction of a day. Unlike a date whose starting point 

can depend on various factors, a time is usually stated to start on a non-spatial point called 

midnight. 

Like a date, a time is represented with a combination of numbers and special characters. Like a 

date, the character used depends on the language you are using. The character used can be checked 

in the Regional Settings of Control Panel in the Time property page 
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 To represent time, a day is divided into 24 non-spatial fractions and each of these fractions is 

called an hour. Each hour is divided into 60 fractions and each fraction is called a minute. The 

minutes are counted from 0 to 59. Each minute is divided into 60 fractions and each fraction is 

called a second. The seconds are counted from 0 to 59. Each second in divided into 1000 

fractions and each fraction is called a millisecond. The milliseconds are counted from 0 to 999. 

The milliseconds are hardly used, only in extreme mathematically-oriented operations. To 

separate the sections of a time, you use a special character. In US English, that character is the 

colon. Therefore, 8 o'clock can be represented as 8:00 

There are two ways to represent a time in a day. First, a day with light is divided into two 

sections. The first part is called morning. The other part is called afternoon. The period that 

divides them is called noon. One way you can represent a time, also called the military standard, 

counts the hours from 0 to 23. Using this technique, any time before 10 is represented with a 

leading 0. A time commonly called "8 o'clock" or "8 in the morning" is represented as 08:00. An 

equivalent time in the second part of the day is represented as 20:00. Using this military time, 

you don't actually don't indicate whether the time occurs in the morning or in the afternoon. The 

time stated provides complete information. The other technique of representing time consists of 
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formally indicating in which part (also called a quadrant), the time period occurs. Using this 

technique, the first part of the day is represented with am, Am, or AM. This first part is counted 

from 0 to 11. Therefore, to indicate that the time occurs in the morning, after stating the time, 

you add an empty and type the two characters. An example is: 8:16 AM. The second part of the 

day is represented with the combination pm, Pm, PM. The hours of this part are also counted 

from 0 to 11. To indicate that the time occurs in the afternoon, after stating the time, you add an 

empty and type the two characters. An example is: 8:16 PM. 

Microsoft Excel recognizes all the rules of time representation. Since there can be different 

scenarios to represent a value, it lets you customize how your time should appear 

 

Date and Time Combination  

In some circumstances, you may want a date and a time value values to be considered as one 

entity. This is possible. 

To get the current date and time with one call, you can use the NOW() function. This function 

returns a value in the formula M/D/YYYY HH:MM 

 

 

 

Chapter XII  

Data Analysis With Charts 

Overview of Charts 

Charts are used to analyze data graphically. Good created and formatted charts can help people 

and businesses make decisions based on the impact that their images provide to the users. 

Microsoft Excel is equipped with the Chart Wizard that allows you to create and format a chart to 

suit almost any scenario or need. 

To create a chart, you must first decide where data is coming from. This is mostly done with 

information available on a worksheet. Formatted charts come in various flavors for diverse goals, 

ranging from columns to pies, from lines to surfaces, etc. 

A chart is usually created on a two-dimension basis, which relates to data on columns and rows 

on a worksheet. Overall, once you have decided on the data source, you have a great deal of 

freedom on the design process. This means that you control what pieces of information will be 

available on the chart, how the chart will be displayed, whether to display the chart on the 

originating worksheet or a separate one. 

A chart is made of different sections. The main area allows users to view the graphical display of 

data, the legend explains the meaning of various colors on the chart, the title indicates what the 

chart is used for. When designing one, the charts in Microsoft Excel are organized by types 

including columns, bars, lines, pie, etc. 
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When creating a chart, you will mainly be influenced by the kind of information you intend to 

analyze. Data that deals with scaled numbers such as monthly sales or student grades are suitable 

for column or bar charts. If your data is about percentage or fractions, you should use pie or 

doughnut charts. Microsoft Office ships with Microsoft Map, a special software product that 

allows you to create a mapped chart used to analyze data geographically, depending on the country 

or a region of the world. 

 

Creating a Chart 
 

When creating a chart, first find out what the chart will be used for, this allows you to get 

necessary data available. Once the originating data is available on a worksheet, select Microsoft 

Excel can recognize data format and act appropriately. To create a chart, you will primarily use the 

Chart Wizard which will take you step by step in creating the object. To start, select data intended 

to be analyzed, then on the Formatting toolbar, click the Chart Wizard button, and proceed. Charts 

come in different types for various purposes 

 

 
 

 

Types of Charts 

 

A column chart can render a very effective result when analyzing data of the same category on a 

defined scale. The column chart emphasizes high and low values. It helps to compare items. 
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The classic column chart is made of flat bars that simply illustrate maximal, minimal, and in-

between values. One of the options allows you to create a 3 dimensional look of the chart and 

further accentuate the colors and/or other graphic effects. To enhance an effective analysis, you 

can create a real 3-D chart that shows data and graphics in perspective. 

 

 

 

Column Charts 

A column chart can render a very effective result when analyzing data of the same category on a 

defined scale. The column chart emphasizes high and low values. It helps to compare items. 

The classic column chart is made of flat bars that simply illustrate maximal, minimal, and in-

between values. One of the options allows you to create a 3 dimensional look of the chart and 

further accentuate the colors and/or other graphic effects. To enhance an effective analysis, you 

can create a real 3-D chart that shows data and graphics in perspective. 

 

 
 

 

Bar Charts 
Like the Column, the Bar chart is used to compare values of the same category on a common scale. 

This time, the chart is drawn horizontally. You create a Bar chart using the same process as the 

Column, except that you should select the Bar in step one. 

 



66 

 

Pyr@mide Corpor@tion 

Site web: www. pyramidecorporation.com 

Email: info@pyramidecorporation.com 

Tel: 0788620201 
 

 
 

A column chart can render a very effective result when analyzing data of the same category on a 

defined scale. The column chart emphasizes high and low values. It helps to compare items. 

The classic column chart is made of flat bars that simply illustrate maximal, minimal, and in-

between values. One of the options allows you to create a 3 dimensional look of the chart and further 

accentuate the colors and/or other graphic effects. To enhance an effective analysis, you can create a 

real 3-D chart that shows data and graphics in perspective. 


